About IND$FILE GET and text files

TSO Programming, ISPF, SDF, SDSF and PDF, FTP, TCP/IP Concepts, SNA & SNA/IP etc...

About IND$FILE GET and text files

Postby makoki » Mon Jan 19, 2009 10:12 pm

Hi all,

I'm new to this forum and also new on IBM Mainframe programming.

Recently I've wrote a program that generate a text files. This text files contains a several spaces on the right of each record. When I download those text files into my computer, these spaces disappears. I have to include a character (a '#') to the end of each record to get the record length that I need.

Unfortunately, this is not the best way to do what I need, because I need to run other application to extract this additional character. It would be nice if there's any way to get the file like I want without to have to include this # character.

Any suggestions?

Thank's in advice and regards,

Ferran.

PS. Sorry about my English. I know, is not enough good.
makoki
 
Posts: 5
Joined: Mon Jan 19, 2009 9:47 pm
Location: Barcelona

Re: About IND$FILE GET and text files

Postby dick scherrer » Mon Jan 19, 2009 10:31 pm

Hello and welcome to the forum,

Sorry about my English. I know, is not enough good.
Opinions vary. I believe your English is quite well done.

Many file transfers are set up to remove trailing blanks to reduce transmission time.

Suggest you try ftp to download the file rather than ind$file. If you intend to use ind$file, suggest you talk with the system support people to learn if something in your configuration can be changed to preserve the trailing blanks.
Hope this helps,
d.sch.
User avatar
dick scherrer
Global moderator
 
Posts: 6324
Joined: Sat Jun 09, 2007 8:58 am

Re: About IND$FILE GET and text files

Postby makoki » Mon Jan 19, 2009 11:33 pm

Thank's for you reply, Dick.

I'm not sure, but I think that ftp is disabled by the System Administrators. I'm going to ask him about that tomorrow, perhaps there's a way to enable ftp for this porpouse. If not, I will try to find more information about ind$file.....

If I find something, I will post it here.

Thank's again,

Ferran.
makoki
 
Posts: 5
Joined: Mon Jan 19, 2009 9:47 pm
Location: Barcelona

Re: About IND$FILE GET and text files

Postby dick scherrer » Tue Jan 20, 2009 6:40 am

Hi Ferran,

I think that ftp is disabled by the System Administrators.
Most often a desktop is not set up as an ftp server, but almost all pcs have an ftp client. Usually someone uses their mainframe id to use mainframe-based ftp.

Are you issuing ind$file from a tso command prompt? What options are specified? I seem to remember a -f that was to do deal with trailing blanks/space, but it has been a long time. . .

Good luck,

d
User avatar
dick scherrer
Global moderator
 
Posts: 6324
Joined: Sat Jun 09, 2007 8:58 am

Re: About IND$FILE GET and text files

Postby makoki » Tue Jan 20, 2009 1:34 pm

Hi Dick,

I'm using ind$file from IBM Workstation program itselt, not writting the command directly on the emulator. The options that are sent to the HOST are ACSCII CRLF. Seems that CRLF option deletes trailing spaces and inserts carriage return/line feed characters when a file is stored on the PC. Well, this is not good for me, I need both (CRLF and trailing spaces).

I have tried this on the ISPF TSO or Workstation command:
Code: Select all
IND$FILE GET 'C988.FIX.C4445.P0060001' ASCII CRLF -f
.

But gives me a "INVALID KEYWORD -f" error.....

Thank's again Dick,

Ferran
makoki
 
Posts: 5
Joined: Mon Jan 19, 2009 9:47 pm
Location: Barcelona

Re: About IND$FILE GET and text files

Postby Bill Dennis » Tue Jan 20, 2009 7:51 pm

Find where the Tranfer Type is defined and add the Additional Option NOTRUNC to prevent this.

In IBM PCOM, it's under toolbar Edit...Preferences...Transfer...MVS/TSO and modify TEXT or use it as a model for a new TEXT80 type.
Regards,

Bill Dennis

Disclaimer: My comments on this forum are my own and do not represent the opinions or suggestions of any other person or business entity.
Bill Dennis
 
Posts: 279
Joined: Thu May 15, 2008 9:45 pm

Re: About IND$FILE GET and text files

Postby makoki » Wed Jan 21, 2009 1:54 pm

Hi Bill,

I don't see NOTRUNC option into the Text transfer type. I have ASCII, CRLF and Append options, but there is not a NOTRUNC option into MVS/TSO section of these preferences.

Perhaps it's a matter of the IBM PCOM application version. I have installed the 5.7 version. ¿There's a higher version that includes that option?

Thank's

Ferran.
makoki
 
Posts: 5
Joined: Mon Jan 19, 2009 9:47 pm
Location: Barcelona

Re: About IND$FILE GET and text files

Postby Bill Dennis » Wed Jan 21, 2009 10:04 pm

You must add it yourself in the Additional Options area for the Transfer Type that you use. Then click on SAVE to save the changes.
Regards,

Bill Dennis

Disclaimer: My comments on this forum are my own and do not represent the opinions or suggestions of any other person or business entity.
Bill Dennis
 
Posts: 279
Joined: Thu May 15, 2008 9:45 pm

Re: About IND$FILE GET and text files

Postby makoki » Thu Jan 22, 2009 1:50 pm

Great Bill!

Now It works as I want!!!!!

Thank's again and regards,

Ferran.
makoki
 
Posts: 5
Joined: Mon Jan 19, 2009 9:47 pm
Location: Barcelona

Re: About IND$FILE GET and text files

Postby DRIQU » Wed Feb 17, 2010 2:35 pm

Hy

thank you for your help
the option notrunc is wonderful

Driqu (i'am french , sorry for my english)
DRIQU
 
Posts: 1
Joined: Wed Feb 17, 2010 2:31 pm

Next

Return to TSO & ISPF

 


  • Related topics
    Replies
    Views
    Last post